
Using Triton BathyProRT (Real Time) 
The following description includes the basic settings required to start a Real Time BathyPro logging and display session, with the 
generated Bathymetry DTM appearing in the Triton Map window during acquistion.  It includes configuration of the connection to 
the sonar and other sensors.  It also describes how to configure Virtual Serial ports, and how to configure Triton Map/Nav to 
display the vessel position. And finally how to setup BathPro RT to display the Real Time Bathy data. 

After deciding which type of sonar you will be using you may read the whole Guide for the "full story" or: 

Use these links to jump to these tasks: 

� Setting up Triton Isis (MB/SS-Logger) 

� Connect Isis to a Reson 81xx sonar 

� Connect Isis to a Reson 7125 sonar 

� The STOP, RECORD and SWITCH buttons. 

� Connecting the POS/MV sensor using the POSRAW option. 

� POS/MV configuration 

� Isis POS/MV Ethernet Configuration 

� Isis serial UTCTIME Configuration  

� Display the Port Monitors 

� Logging data to an XTF file. 

� Setup a Virtual Serial port pair. 

� Setup Triton Nav to show the vessel shape. 

� Setup BathyPro RT to display the Real Time bathy data. 

� Problems and Messages 

Setting up Triton Isis (MB/SS-Logger) 

The first task is to connect Isis to the sonar and make sure that data is being displayed and logged correctly. 

When setting up Isis for the very first time, or if you are changing the type of sonar or making other major configuration changes 
its always a good idea to use the Reset to Factory configuration option: 

Start Isis and Click Configure>Reset to Factory Config - allow Isis to restart. 

Reson Seabat 81xx series sonars (8101, 8125,) 

All the 81xx series of sonars use the same software server to connect Isis to the data stream; the name of the server is 
Sbat8100.exe. 

Launch Isis, and click on File > Record Setup: 
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Click Record Setup, and select Reson Seabat 81xx from the drop down menu on the right: 

 

In the Seabat 81xx Setup dialog be sure to select Side Scan (even though you may not be using the side scan option, simply leave 
the Off  checkboxes checked) 

Hit OK, OK and OK to these 3 dialogs to return to the main Isis window. 

Hit the Red Record button    in Isis, this will launch the Isis Seabat 81xx server:  

The server can be used with a number of different Reson 81xx sonars.   
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The majority of the settings in this dialog box are simply remote versions of the local controls available from the Reson 8100 
topside, we can ignore them for the moment.  Click Setup Comms to open the main Comms setup dialog: 

 

This guide deals with the newer Ethernet (LAN) connection method.  There is also the possibility to connect bathy data via a serial 
port.  Do not confuse this with the ability to Control the sonar using a serial port; checking the Enable serial commands to 
Seabat box allows the setting up of a serial port for that purpose.  It requires that you connect and configure a serial port on the 
Isis PC to the Control port on the Reson topside unit. 
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Ethernet Communications 

In order for the sonar to communicate with the Seabat Server both need to be connected via the network; the IP address of the PC 
that is running Isis and the Seabat server needs to be in the same range as the IP address of the Reson topside.  You can check the 
local IP address by clicking the Show Network Config button: 

 

The important settings here are the IP Address (10.0.0.56) and the subnet mask (255.255.255.0) 

To be in the same range and to communicate with the Reson topside the first 3 numbers of the IP address of the Network Interface 
Card (NIC) on the PC must be the same as the first 3 numbers of the IP address of the NIC in the Reson topside.  The last number 
must be different. 

For example a Reson topside with an IP address of 10.0.0.55 and Subnet Mask 255.255.255.0 would work fine with the above 
settings 

Ethernet base UDP port:. 

Enter the correct value for the Reson topside here, for example 2000; in this case the server looks for the Bathy data on port 2000, 
the sidescan data on port 2001 and the snippet data (if present) on port 2006. 

Show Head Orientation and Show Absorb and Spread loss are advanced settings in the main Seabat 81xx server, and again 
require that a serial control link be in place to the 8101 sonar. Changing these values should not be undertaken without being sure 
of the new values; for example mistakenly reversing the head orientation could cause logged data to be useless.  Again, this is a 
remote control function via a serial port.  If a serial control port to the Reson topside is not connected and configured these 
controls do nothing. 

Hit OK when all is set. And then the ON-LINE checkbox in the Isis Seabat 81xx Server: 

Page 4 of 40Using Triton BathyProRT

4/24/2011file://C:\Guides\BathyPro_RT\bathypro_RT.htm



 

If the connection to the sonar is OK you will get an indication of the data types being received by the server.  In this case we have 
Bathy and Sidescan data.  If the serial control port to the Reson topside has been activated an indication of the commands being 
sent is displayed in the window below; the image shows that the Sound Speed command has been sent to the Reson topside and 
has been set to 1500m/s. 

The main Isis window should look something like this: 
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There is no Navigation, and no Sensor Data (Pitch, Roll, Heading, Speed), we have not configured the navigation or motion sensor 
yet.  However there is a sonar range (50m) and the ping numbers (in this case one for the side scan and one for bathy) are 
incrementing. 

You have successfully interfaced Isis to the Reson 8100 sonar. To stop acquisition and disconnect Isis from the sonar hit the Stop 

 button: 

To save all settings so far hit the Save button  

You can also hit Stop and Exit  then Save Setup: 
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All settings will be saved and applied on re-start. 

  

Reson 7125 server setup. 

The Reson 7125 sonar interfaces to Isis with a different server: 

NOTE  "When setting up Isis for the very first time, or if you are changing the type of sonar or making other major configuration 
changes its always a good idea to use the Reset to Factory configuration option" 

Launch Isis and click on File>Record Setup 

 

Select the Reson 7125 sonar: 
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With this server there is no need to enable Side Scan unless you need it.  Hit OK, OK and OK to close all dialog boxes and return 
to the main Isis window: 

Hit the Red Record button in Isis  and the Reson 7125 server will launch: 

 

If the 7125 sonar is not found or is on a different IP address from the standard Reson IP (192.168.5.121) then the message Error 
connecting will be displayed, shortly afterwards the following dialog will appear: 
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Once the settings are correct (enter the correct IP address in the Sonar IP address window) the server display changes to: 

 

Note that in most cases it is not necessary to change the Sonar Control Port number (7000) 

The main Isis window should resemble this image: 
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There is no Navigation, and no Sensor Data (Pitch, Roll, Heading, Speed) we have not configured the navigation or motion sensor 
yet.  However there is a sonar range (20m) and the ping numbers (in this case one for the side scan and one for the bathy) are 
incrementing. 

You have successfully interfaced Isis to the Reson 7125 sonar. To stop acquisition and disconnect Isis from the sonar hit the Stop 

 button.  Note that the Reson 7125 server will close at this point, you have disconnected Isis from the sonar. 

To save all settings so far hit the Save button  

You can also hit Stop and Exit  then Save Setup: 

 

All settings will be saved and applied on re-start. 
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The STOP, RECORD and SWITCH buttons. 

It is important to understand the functions of these buttons. 

 The RECORD button puts Isis into acquisition mode, launches any configured servers and attempts to connect with the sonar
(s) and displays the data, it does NOT however start logging data. 

  The STOP button disconnects Isis from the sonar(s) and takes Isis out of acquisition made.  All basic configuration settings 
must be completed while Isis is STOPPED. Usually, hitting the STOP button will also close any active servers. (but not always! 
see 8101). 

It is almost never a good idea to hit the STOP button while conducting a survey unless the survey is complete or the sonar has to 
be recovered.  Under normal operations, when the sonar is deployed and active Isis should always be connected and displaying the 
data.  To change lines, Start or Stop logging use the Switch button. 

 The SWITCH button should be used to Start and Stop logging of data to the hard drive, this will be discussed in full later,  
while the sonar is connected hit Switch, as a minimum enter a drive letter (C:\, D:\ etc) and hit Switch Now! Isis will start logging 
an XTF file with a default name based on the Julian Day and the time.  Hit Display Only and Switch Now! again to stop logging. 

Connecting the POS/MV to Isis using the POSRAW option. 

NOTE:  If you are using the POSMV Viewr software you MUST connect Isis to the POS first, and then launch POSMV View. 
Running POSMV View software first will prevent Isis from acquiring the POS data. 

The POS/MV sensor is a Position and Orientation System for Marine Vessels, it provides both accurate navigation data and the 
high speed attitude (Pitch, Roll, Heave and Heading) data needed to correct for the effects of vessel motion during survey 
operations. 

There are two connections needed from the POS/MV controller; an Ethernet (LAN) connection and a single serial data 
connection.  The Ethernet connection provides all the positioning and motion reference data via Group 102 Ethernet Real Time 
logging.  The serial data connection provides an NMEA UTC time string to ensure that the system clocks are synchronized.  The 
UTC time string is also received by the Reson sonar.   By this method all systems are synchronized to a common time reference. 

POS/MV Configuration 

Consult the POS/MV manual for details on setting up and calibration of the unit, screen shots of the two needed outputs as 
configured from the POS/MV controller software are shown below: 

 

If you are processing True Heave you also need to check "111 Heave data" and "113 Heave data quality control" 
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Group 102 Ethernet logging. 

 

NMEA UTC serial data string. 

The screen shots show the default update Rates, however the POSMV supports update rates of up to 200Hz.  The Group 102 data 
over the Ethernet should be updated as fast as possible, however the UTC string can be left at 1Hz. 

See the POS/MV manual regarding the IP address setting of the PCS.  In general it will need to be in the same range as the 
Network Interface card in the Isis PC - recall that this means the first 3 groups of digits must match but the final one must be 
different.  

Isis Configuration - POS/MV Ethernet connection 

If Isis is running hit STOP   

Launch Isis and click on File>Record Setu 

 

Click Serial Ports and then the POSRAW button to display the POS MV setup Dialog. 
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NOTE: You should setup the POSRAW interface BEFORE you configure any conventional serial ports, otherwise you will need 
to temporarily disable convention ports to avoid the error message. 

Note that the default Port number is 5602, this should be correct for a standard POS/MV  

If the POS/MV is correctly configured and is sending data, when the Test checkbox is checked the raw POS data can be seen in 
the test window of the dialog box. 

 

Clicking disconnect results in this message: 
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Monitor  is a useful QC tool, check the On checkbox and enter a suitable name for the device: 

 

Click OK, OK and OK to return to the main Isis window. 

Isis Configuration - Serial UTCTIME string. 

Return to the Serial Port setup; File>Record Setup>Serial Port, make sure that a serial data cable is connected from the selected 
POS/MV port to a suitable COM port on the Isis PC. 

Choose the serial port and baud rate you will use and click the UTCTIME  button: 
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You may also set up a Monitor  in a similar way to the POSdata described earlier. 

To test the connection click the Test button, if the UTC time string is active and correctly configured the COM port test page will 
look similar to this: 

 

Click OK, OK and OK to return to he main Isis window: 

Hit the Record  button: 

If all sensors including the sonar are connected and running the Window will display as before: 
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Note that now we have Navigation, Pitch, Roll, Heading, Speed, Gyro and Heading Displayed. 

To save all settings so far hit the Save button  

You can also hit Stop and Exit  then Save Setup: 

 

All settings will be saved and applied on re-start. 

Display the Port Monitors 

To display the port Monitors for UTCTIME and POSdata click Window>Status and Control>IOPort Monitor:  
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If data is good then the monitor will show green: 

 

If the data are interrupted for more than the trigger time (the default is 1000ms) then the indicator flashes an alarm condition: 

 

  

Logging Data to an XTF file. 

Using the  button. 

Isis should be running, connected to the sonar, with the navigation and attitude displayed; we are ready to log an .XTF file: 

Click the Switch button, the Switch File dialog opens 
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Enter the drive letter that you want to use to log the data: 

 

And hit Switch Now! 
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If no filename is specified Isis uses the current day and time for the filename (290-1048.XTF in the example) 

To stop logging check the Display Only checkbox and then hit Switch Now again: 

 

NOTES: 

You can specify your own file name and also a specific directory, however you must create the directory first!  If you specify a 
non-existent path/path Isis will crash! 

You may log across a network, however the drive letter must be mapped and appear as a drive on the local machine. 
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If you specify a filename and do not change it manually Isis will automatically add 1 to the name each time the Switch Now button 
is used to start logging.  So LINE.XTF will become LINE1.XTF, LINE2.XTF etc. 

See the Isis manual for More>> options associated with the Switch File dialog. 

Setting up a Virtual Serial port pair 

Virtual serial ports are set up as pairs of ports on a system. They allow data to be transferred as if real serial ports existed with a 
serial cable connecting them.  There are several commercially available programs that implement these ports. 

http://www.virtual-serial-port.com/ 

http://www.virtualserialport.com/ 

There are also a freeware versions, follow this link to download one from the Triton Imaging website: 

http://www.tritonimaginginc.com/site/content/public/downloads/Tools/VirtSerial.zip 

This is freeware, if you decide to use it the normal restrictions apply, you must read the enclosed readme.txt and be prepared to 
abide by the conditions. 

It is usually best to set Virtual pairs of serial ports on high numbered COM ports, typically COM 10 and above.   However beware 
of assigning COM port numbers higher than 16, some applications (including Triton's) cannot address COM port numbers higher 
than 16. 

In the following description we have used COM 10 and COM 11 to send the navigation from Isis to Triton Nav to give a 
continuous display of the vessel's position. 

Setting up Triton Nav to display the vessel shape. 

In conjunction with Isis, BathyProRT will provide a display of the Bathymetry in real time as a color coded layer in the TritonNav 
window.  However as we shall see, this display is only available while the Bathymetry is being logged to an XTF file, once 
logging stops the bathy display will also stop.  It is very useful to have a display of the vessels position at all times even when the 
bathy data are not being logged.  We can use the ASCII report function from Isis to send the real-time vessel position to Triton 
Map over a pair of Virtual Serial ports. 

Step 1 - Configuring ASCII report in Isis 

The following assumes that you have completed the setting up described earlier to interface either a Reson 81xx or Reson7125 
Multibeam echosounder to Isis, and that you have also configured the navigation and other sensors.  You should have Isis running 
and displaying multibeam and navigation data. 

In Isis click Tools > ASCII report 
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Check Form 1 and Setup form 1 then OK 

ASCII report Form 1 opens: 

Page 21 of 40Using Triton BathyProRT

4/24/2011file://C:\Guides\BathyPro_RT\bathypro_RT.htm



 

Check the box MVP Data 

The following warning is displayed: 

 

Click OK, select VTG and GGA  (course and speed plus position.) 
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Click OK 

Back in the Report Form 1 dialog check these boxes - Click Configure Port last 

 

Clicking Configure Port opens the standard Isis COM port setup dialog: 
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Check the boxes as shown (assuming COM 10 is the output port), note that you must enclose the {TELEMOUT} statement in 
curly brackets as shown.  Hit OK. 

If all is well the Output form 1 window will be open and display something like this: 

 

These are the two NMEA 0183 data strings being sent by Isis to COM 10. 

To save all settings so far hit the Save button  

You can also hit Stop and Exit  then Save Setup: 

 

All settings will be saved and applied on re-start. 

Step 2 - Configuring Triton Nav to display the vessel shape. 

With Isis running and connected to the sonar, launch Triton Map: 
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Triton Nav is a module of Triton Map, when Triton Map launches you should see the survey control panel on the right side of the 
main window (see below), if you do not, make sure that Survey Control Panel is checked in the View menu: 
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Click the Acquisition Setup Serial port button.  

In the Serial port data acquisition setting dialog check these settings: 
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Use the small Left/Right arrow to locate the  COM 11 tab, click it and then the  button, the input will default to 
NMEA0183 as shown.  Click the Show Server button to launch the serial server. 

The Serial Server for Triton Map will launch minimized as an Icon in the Task bar: 

 

Click the Icon to make the Server Dialog available: 

 

Click 11 then the On checkbox and finally the Spy button.  You should see the NMEA0183 VTG and GGA data being sent from 
Isis in the small window.  The Spy pushbutton only remains active for about 30secs, after that time the window will stop updating 

- however oxygen continues to flow... You may minimize the serial server by clicking  

Click OK in the Serial Port data acquisition Settings dialog to close it, notice that on the lower right side of the Triton Map 

window you now have COM 11 (boat) displayed, click the Start/Stop serial input button:  

After a brief pause the following dialog box will appear: 
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You need to select the Geodesy for your project in Triton Map.  This will almost always be the default Universal Transverse 
Mercator projection, (although many others are available) - Click Next  

The Zone defaults to 31 (0E > 6E) and North hemisphere: 

 

You MUST select the correct zone and hemisphere at this point, in our example the Longitude of the data is -119 degs (W119) so 
choose Zone 11, the Latitude is North:  
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Hit Next 

You may also select a different Datum, WGS Datum 1984 is the default: 

 

Hit Finish 

If this is the first time you have set this up there will be a lengthy pause (around 1 - 2mins) while Triton Map configures the 
Projection information, eventually the main screen should start displaying the vessel and the track: 
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NOTE: You should have sensible information over on the left side Lat/Long display, the acquisition button is now green and there 
is a small indicator showing serial port activity in the lower status bar. 

Save these settings in Triton Map: 

Hit Settings>All Settings and choose a working folder DO NOT choose the default, create a new folder and set up a project and 
associated folders: 

Page 30 of 40Using Triton BathyProRT

4/24/2011file://C:\Guides\BathyPro_RT\bathypro_RT.htm



 

Then Hit Project>Save As and choose a name. 

You should now have Isis and Triton Nav running, the main window in Triton Nav will show a small boar symbol and the boat's 
track will be red. 
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Setup BathyPro RT to display the Real Time bathy data 

This is the final step, you should have completed all the previous steps... 

In Isis click Tools>RealTime BathyPro Map>MultiBeam Bathymetry: 

 

The BathyPro RealTime Interface will launch: 
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Also, because we already have Triton Map open the following dialog will appear: 

 

At this point BathyPro automatically tries to launch Triton Map, click Yes 

WARNING The Isis waterfall window, when active is ALWAYS on top, (this is by design)  both these messages may 
appear UNDERNEATH the main Isis window; if they do not appear, move the Isis window to one side. 

The BathyPro RT dialog: 

DTM File settings 
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This dialog box determines where the .DDS_VIF Image file with the Real-Time bathy data will be stored, note that it will be 
located in the same folder that was setup earlier in Triton Map as the Working Folder.  You may also change the name of the file, 
the default is grid00000.DDS_VIF click Select to change. 

Encoding type, for a RealTime bathy display choose either Last or First.  For QC purposes this can be useful to show 
discrepancies between adjacent lines, the other options are also valid.. 

 

Hit OK to exit and continue 

Map projection and settings dialog: 

 

Beams Inside/Outside - during acquisition the number of beams inside and outside the working area are display here on a per 
ping basis. 

Click the Settings button to open the Map and Projection dialog: 
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BathyPro needs to create a grid file before writing the bathy data into that file and displaying it in Triton Map, you need to set up 
some basic information in this dialog box.  Much of the information is already correct if you have set up the vessel display earlier, 
all that remains is to input three things: 

The Boundaries - the E-W and N-S size of the working area. 

The Origin  - if Auto Detect is checked BathyPro will fill in the current Lat/Long from Isis, you have to decide if this is close to 
the center of the area, or the top left bottom right etc. you may also uncheck Auto Detect and enter all the values manually. 

The Resolution -  is the size of one pixel in the bathy display.  For water depths around 25m - 50m a resolution of 1m is probably 
about right.  If the water depth is greater than 50m then a lower resolution should be chosen. The real resolution of the bathy data 
will decrease as the water depth increases,  in a water depth of 1,000 meters the bathy swath may be as much as 3,000m, 
attempting to map this swath at 1m meter resolution would probably not work.  On the other hand it might be possible to use a 
higher resolution in shallow water.  The value will be determined by the water depth and to a lesser extent, the sonar specification, 
number of beams etc.  Also note that you must tell BathyPro if the water depth is greater than 2,000m. 

For a RealTime display the Processing settings can be left at default settings, consult the BathyPro processing guide for more 
information. 

Hit OK to save these settings. 

Start logging an XTF file in Isis. 

In order to display a real time DTM you MUST be logging an XTF file in Isis see Logging data to an XTF file 

Note: It is also possible for demonstration purposes to use an existing XTF file and run Isis in playback mode, the important point 
is that BathyProRT needs an XTF file from Isis. 

With Isis logging click START in the BathyPro Real Time Dialog: 
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First the message "Grid file xxxxxx has been created" then "Adding geoencoded information to xxxxx" will appear in the lower 
message window.  The ping number between the START and STOP buttons will start to increase and, if the data are inside the 
specified box the "Beams Inside" value will start to increment.  At the same time a realtime bathy display will show up in the 
Triton Map window: 
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Note that the project window on the left can be expanded to show the various layers that are visible in the Triton Map window.   
There is the image layer containing the color coded Bathymetry (grid0001), and also three vector layers: 

Swath - The true port and starboard extents of the bathy coverage. 

Track  - The vessels track 

Coverage - a vector graphic showing the position of each bathymetry swath. 

Right -clicking on any of these layers allows you to control the color and type of these layers. 

In the above image the swath extents are in black and the Triton Map background has been set to grey (GIS Tools > Background 
Color) 

   

IMPORTANT - Shutting the programs down. 

When you want to close everything down do so in this order: 

1. Stop logging in Isis. 

2. Hit the STOP button in the Bathypro Real Time dialog. 

3. Close Triton Map. 

4. Close the BathyPro Real Time dialog. 
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5. Hit STOP in Isis and then Close Isis. 

Problems and Messages 

There are several programs running on the same PC with data being exchanged between them.  If invalid data is transferred from 
one application to another it can cause problems,  for example if the UTM grid Zone is not set correctly the data will not show up 
in the Delphmap window.  It will also not show up if the position is outside the specified area. 

The lower window in the BathyPro real time display may show the following messages: 

"Grid File nnnnn has been created".   Normal message, this happens each time a BathyProRT session is started. 

"Adding geoencoded information to nnnnn"  Normal message, data should be displayed in the Triton Map window. 

"Waiting for a file name from Isis" Isis may not be logging an XTF file, start logging in Isis should correct this problem. 

The small window between the START and STOP buttons will normally display an incrementing number if all is well.  If the 
position is outside the defined survey area it will display Outside 

Under these conditions the Beams Outside number will also start incrementing, probably all is well, you just need to move back 
into the area.  But this could also be caused by incorrect settings. 

During the setting up of the Map and Projection information the following message will be generated if the Lat/Long being sent by 
Isis is not in the chosen Zone or Hemisphere: 

"Invalid projection or Geographical Limit"  

Check that the Longitude in the navigation data falls inside the chosen UTM zone (also check East/West and North/South) 

Sometimes everything may appear OK but nothing happens in the Triton Map display and the message "Waiting for a filename 
from Isis" is displayed even though a file is being recorded.  

This problem can occur if the Bathypro real time dialog is closed prematurely without hitting the STOP button. 

Try closing everything down and restarting. 

If all else fails locate and delete any or all of the following .INI files (new ones will be created automatically, you will need to re-
enter all parameters) 

Bathypro.ini  - Located in C:\Program Files\Triton Imaging, Inc\Triton BathyPro 

Delphmap.ini - Located in C:\Program Files\Triton Imaging, Inc\Triton DelphMap 

TritonSerial.ini and TritonSerialDll.ini  - Both located in C:\Program Files\Triton Imaging, Inc\Triton Nav 

ProjWizard.ini and HydroNavInfos.ini , - Both located in C:\WINDOWS  
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