Setting up Isisto record data from a Side Scan Sonar

Setting up Isis (MB/SS-Logger) to record data.

Connecting the sonar

Specific Sonar Types

Interfacing the navigation

NMEA0183

Non - NMEAO0183 (Custom Navigation string)

Serial Monitor

The File Format button

Hypack

Logging Data

General procedure, applies to all sonar types

Start Isis, the initial screen should look like the image, note that a screen resolution of 1280 x 1024 is needed for correct window
placement. Some 3rd party display managers may cause the | sis Parameter display and/or the Bottom Track Primary Towfish
dialog boxes to display under the the main waterfall, window. |f this happens try turning the Display Manager software off (there
isusualy some indication of these applications in the Windows taskbar).
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Click on File>Record Setup, from the Record M ode Setup dialog click Sonar Setup

file://ID|/Guides/Isis Record_Setup/setting_up_isis_to_record_data f.htm (2 of 15)1/2/2008 8:11:54 AM



Setting up Isis to record data from a Side Scan Sonar

sis - Main Window

File: I Corfigure  Color  Wiew  Tools  Window  Help ¢:|

Serial Ports File Format Ethermet LOP |
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Depending on the type of license you have you may only see one or two sonarsin the Select Sonar dialog, also if you have an SS-

Logger license you will be running SS-Logger which only shows the Sidescan/Subbottom sonars, if you have MB-Logger you will
only see the Multibeam/Bathymetry sonars. In other respects SS-Logger and MB-Logger are similar to MB/SS-Logger (Isis). The
full MB/SS Logger will be described here.

Select the sonar you will be using and click OK and OK to return to the main Isis window.

Click the red Record button to have Isis attempt to connect to the sonar:

o

At this point Isiswill launch the server for the selected sonar. If everything has been setup correctly, and the towfish and its topside
are powered up, the waterfall window will become active and start scrolling, there maybe little or no signal (perhaps the fishison
deck) but you should still be able see the ping number incrementing, NOT SAVING will be displayed and the date/time will update:
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I 1sis Parameter Display ﬁ
Mavigation Sensor Data Range Scale Cursor Current File
Pitch: 0.0 14.6m [ Time: Fing: -
Morth: 0.0 Roll: 0.0 . : Channel: Depth: 1r~lame: NOT SAVING
East: 0.0 fiHeading: 0.0 Display units Range: Al —iDate. 06 MAR 2007
Ship Speed: 0.0 & melers Hdng: Time: 17:21:42 . 800
Speed: 0.0 fDepth: 0.0 T feet Lat: Ping: 140
Gyro: 0.0 fi Al 0.0  ms Long: Disk Left: 10.61% Switch
Note

Y ou can assume that Isis has connected to the sonar.
Specific Sonar types
Separate documentation for details of specific sonar software servers and how they are configured and interact with Isis.

Edgetech 4200

Edgetech FSIU (Includes FS-AS and DSS4200)

Benthos 1624

Klein 3000 and Klein 5000

Benthos C3D

Interfacing the navigation data

If Isisisin Record mode (connected to the sonar), first hit the Stop button:

| |

Thiswill disconnect Isis from the towfish, allowing you to setup the navigation datainterface.

Click File>Record Setup. From the Record Mode Setup dialog click Serial Portsto display the Serial Port Setup dialog:
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n Isis - Main Window
T
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Select the radio button for the serial port you will be using and then the Status ON check box:
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g Serial Port Setup
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The dialog controls become active at this point alowing you to configure the settings for the selected COM port, Baud Rate, Data
Bits, Parity etc. In most cases the defaults will work fine.

Many of the buttons in the Navigation and Telemetry area are not relevant to this description; only the NM EA0183 and the Hypack
buttons will be discussed. The others are used for other serial interfaces such as Motion Sensors and some Multibeam sonars.

NMEAOQO183
Click this button to enter NMEA0183 in the template box:

Mavigation,/Telemetry Template

SeaBat #1 || [INMEELTHE: s
SeaBat#2 | HYPACK POS/MY |
EchoScan #1| TrackPointll|  SeaPath |

EchoScan #2 UTC Time
ELAC | POS Raw
Sk 2000

| IMMEAD &3 i

Almost al the common NMEA sentences are handled using this setting, for full details consult the Isis manual or the Isis help file:

To get help click Help>Contents and Type NM EA0183 and click Display to bring up the NMEA Help topics:
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El !lﬁl_Help Topics: Isis

Index |Fir-..;| |

1 Type the first few letters of the word you're looking for.

[HMMEA,

2 Click the index entry wou want, and then click Dizplay.
Filkers w
Topics Found |;| E

Click a topic, then click Dizplay.

Dizabling ASCI Reports Produced by MMES Packets

Exarplz of Template Construction

How lziz Deals With Heading lszues in MMEADTE3 Stingz
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Dizplay Cancel |

Dizplay Frirt... I Cancel

In general the following NMEAQ0813 sentences are recommended:

$GGA - Position

$VTG - Speed and heading

$ZDA - Precisetime

Asaminimum you should have $GGA to record valid Sidscan Data that can be mosaiced.

Almost all GPS receivers send these strings, many send alot more, Isiswill ignore those that it does not need. However the
navigation interface may work more efficiently if you disable some of the un-needed sentences using the GPS receivers settings.

Non NMEA (Custom navigation data string)

Isis can parse almost any serial data string and correctly assign the values to relevant placesin the XTF file, to do thislsisuses
template tokens which are entered in the template window in the Serial port dialog:
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ﬂ Serial Port Setup
Serial Port Mavigation,T elernety Template
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Isis uses non numeric characters in the string such as commas, spaces etc to separate the valuesin the string, for example:
10/12/2007 10:10:23 E123456.7 N1234567.8 123.4 4.5

The separatorsin this string are /: and <space> also E and N, (Isis treats consecutive separators as one)

So the string would be correctly parsed using this template:

DMYHISENhV

Where:

D = Day (10) M= Month (12) Y = Year (2007) H= Hour (10) | = Minute (23) E = Easting (123456.7) meters

N = Northing (1234567.8) meters h = Towfish heading (123.4) degrees V = Towfish speed (4.5) knots

For afull description of al the available tokens and also some other functions that allow modification of the incoming data see the
Helpmenuinlsis:

Click Help > Contents, enter Navigation and Click Display:
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IMPORTANT - Feet and Meters

Isiswrites al dataan XTF format file. The XTF format does not at this time support navigation coordinates in feet. Only Degrees
(Lat/Long) and meters. If your navigation data are being sent to Isisin feet you must use the special token F at the start of the
template to convert to meters for storing in the file. Using the F token will convert feet to meters by *39.37/12.0 (the conversion
from US Survey feet > meters)

Serial Monitor

For any active serial port you may set up an activity monitor that will give avisual aert if the data flow stops for more than set time:

Check the Monitor On Box, and enter a Name for the data type (e.g. Nav) and set the time out period, most GPS receivers send real
data at about 1/sec so the default 2000mS seems about right.

bl it 1
vV On [View with Windows / Status and Control /
10 Port Monitor)

Trigger if part iz inactive longer thanl 1000 mE

Dizplay nameINa\,i

To seethe alarm indicator click on Window>Status and Display>IO Port Monitor:
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als | Window | Help %
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The File Format button allows you to configure the way recorded data is written to the XTF file. It also alows you to add some
information about the survey that can be embedded in the XTF file. In general it is advisable to leave the settings to the defaults,
however there are some features that can be useful

Hitting the File For mat Button opens this dialog box:
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ﬂ File Format
File Farmat kedia ATF File Header nates
f Q-MIPS | Log to tape Yessel narne;

& HTF
" SEGY [ Opons..

Sample Size to Record

{8 bitz per pixel Jurvey area;
{* 1B bitz per pixel

Samples per Channel ta Record

........................................... Operator name:
1024

2048
403K
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163224 200 char max each. During playback,

Cust I— thig information can be seen in Help -»
o Get Info.

Proceszing Method
(s
i

DO S T B IO B

0k, Cancel

File Format - ALWAY S choose XTF, unless there is some very special reason to do otherwise. Q-MIPS format is no longer
supported and in general the SEGY format is unsuitable for the logging of Side Scan Data

Samples Sizeto Record - 16bits per sampleis strongly advised, some older sonars only sent 8 bits - but these are no longer
supported.

Samples per channel to record

1024 isthe default. For a 100m side scan range this gives an across track resolution of 100/1024 or about 0.1m, if the sonar range is
shorter, say 25m then the across track resolution automatically improves to about 0.025m with this same setting. Y ou may also
choose a higher resolution if your wish, however thiswill entail larger file sizes and make greater demands on the hardware.

No downsampling - this option will log all available samples, with some recent digital sonars this can result in several thousands of
samples/channel and very large file sizes. For example the Edgetech 4200 sonar on the 50m range can generate up to 5000 samples
perc hannel implying an across track resolution of 0.01m!!

Hypack

Thereis a specia button that sets a pre-defined string in the template for the Hypack navigation system. Usethisif Hypack is
interfacing to Isisviaanormal serial port, you will need to choose the corresponding Isis output in the Hypack program.

HDDE if Hypack is running on the same PC as Isis you can also use the HDDE link between the two applications. This has been
recently tested under Windows XP - make sure that you have the latest version of HDDE.DL L and that you have arecent version of
Hypack (v6.2)
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I 1sis - Main Window
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In this mode Start/Stop recording and line naming in Isis are controlled automatically by the Hypack program..

Logging Datato an XTF file.

Switch

Using the button.

Isis should be running, connected to the sonar, with the navigation and waterfall updating:

Click the Switch button, the Switch File dialog opens
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" Digplay Only bore >

{* Record Diata to File Mame  Browse

Current File |
Path:
fiName: NOT SAVING
—[Date: 09 MAR 2007
Time: 10:49:27 . 680
Ping: 371

Disk Left: 9.93

Switch when

orage lesz than 0.5% then
etweeh drivesﬁ and |E_

File grows larger than B

Switch M awl

Enter the drive letter that you want to use to log the data:

i Switch File
" Dizplay Only More >
f* Record Data to File Mame  Browse
E:\
Switch when

I+ Remaining storage less than 0.5% then
ping-pong bebween drivesﬁ and |E_

| File grows larger than B

%

And hit Switch Now!

 Dizplay Only Maore >
{* Record Data to File Mame  Browse
- T
‘Current File I, ||E:"~EIEE-'I 056.=TF J
Path: E} :
Switch wh
fiName: 066-1056.XTF | || > ™" !
__Date: 09 MAR 2007 W Eemalnmg shorage Ie_ss that 0.5% then
Time: 10:56:39 . 910 ping-pong between drwesﬁ and |E_
Ping: 73 | File growes larger than B
i S i
ibLlsk: Left: 9.90% Switch
Switch Mowl
e

If no filename is specified Isis uses the current day and time for the filename (068-1056.X TF in the example)

To stop logging check the Display Only checkbox and then hit Switch Now again:
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(+ Dizplay Only bore »»
" Record Data to File Mame
~ Current File =¥
Path: :
Switch whet
fiName: NOT SAVING v B .
__:Date’ 09 MAR 2007 v Eemamlng zhorage: Ie.ss than 0.5% then
Time: 11:01:51 . 220 ping-pong bebween drwe&ﬁ and E
Ping: 70 | File grows larger than ME
Disk Left: 9.86% Switch
= - Swaitch Mowl
—-:"'FF

To increase the size of the NOT SAVING message click the small icon next to Name:

(®Name:

A larger, re-sizable window opens that will reflect the current logging status:

’g Saving to File kﬂ Saving to File
NOT SAVING C:\068-1117.XTF
or

NOTES:

Y ou can specify your own file name and al so a specific directory, however you must create the directory first.
Y ou may log across a network, however the drive letter must be mapped and appear as a drive on the local machine.

If you specify afilename and do not change it manually Isiswill automatically add 1 to the name each time the Switch Now button
isused to start logging. So LINE.XTF will become LINELXTF, LINE2.XTF etc.

See the Isis manual for M or e>> options associated with the Switch File dialog.
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